Difference between revisions of "WOCE Build Instructions"

From WebOS-Ports
Jump to: navigation, search
Line 43: Line 43:
 
*Clone down the woce-build repo from github. '''git clone https://www.github.com/woce/fuzzy-lana'''
 
*Clone down the woce-build repo from github. '''git clone https://www.github.com/woce/fuzzy-lana'''
 
*Start the build. this is as simple as cd'ing into the woce-build directory and ruuning '''make''' or if you have multiple cores '''make -j<number of cores here>'''
 
*Start the build. this is as simple as cd'ing into the woce-build directory and ruuning '''make''' or if you have multiple cores '''make -j<number of cores here>'''
 +
* IMPORTANT: Ignore patch failures for now, it's a known issue
 
*When the build finishes the binary's will be under the packages folder in their appropriate directories
 
*When the build finishes the binary's will be under the packages folder in their appropriate directories
  

Revision as of 08:09, 27 June 2012

<accesscontrol>hp,Usergroup:Members</accesscontrol>

Supported Platforms

Currently the only supported platform is Ubuntu 12.04. We have tested and confirmed that x32 and x64 Ubuntu Desktop and Server successfully build WOCE. Other platforms may work but are not supported.

Installation on Ubuntu

Prerequisites

Your Ubuntu installation will need the following installed. If you do not have them, run the command after the package name. You can test if they are found by just typing the command name. If it says command not found, you need to install it.

git sudo apt-get install git
gcc sudo apt-get install build-essential
python sudo apt-get install python
curl sudo apt-get install curl
unzip sudo apt-get install unzip

If you're uncertain at all, and you're using Ubuntu 12.04, just cut and paste the following. If they are already installed, they'll be skipped.

sudo apt-get install git build-essential python curl unzip

Note: If you are a beginner with Ubuntu Linux Distribution, you should update all the packages on your system to avoid problems when you will compile.

NOTE: If you are using x64 ubuntu you also need to install the following package

ia32-libs and g++-multilib sudo apt-get install ia32-libs g++-multilib


Start setup

  • Create a WOCE directory, we recommend you place it in your home directory.
  • Clone down the woce-build repo from github. git clone https://www.github.com/woce/fuzzy-lana
  • Start the build. this is as simple as cd'ing into the woce-build directory and ruuning make or if you have multiple cores make -j<number of cores here>
  • IMPORTANT: Ignore patch failures for now, it's a known issue
  • When the build finishes the binary's will be under the packages folder in their appropriate directories

Installing the Binaries

Instructions Coming Soon

You're Done!