Difference between revisions of "WOCE Build Instructions"

From WebOS-Ports
Jump to: navigation, search
(+Installing the Binaries; +Done; formatting; changed instructions generally to Debian-based OSs; other changes)
Line 3: Line 3:
 
Currently the only supported platform is Ubuntu 12.04. We have tested and confirmed that x32 and x64 Ubuntu Desktop and Server successfully build WOCE. Other platforms may work but are not supported.
 
Currently the only supported platform is Ubuntu 12.04. We have tested and confirmed that x32 and x64 Ubuntu Desktop and Server successfully build WOCE. Other platforms may work but are not supported.
  
==Installation on Ubuntu==
+
Older versions of Ubuntu may also work, it's been tested successfully on Ubuntu 10.10. It's also very likely that you'll have success with Debian or Debian-based distributions.
  
===Prerequisites===
+
==Prerequisites on Debian-based systems==
Your Ubuntu installation will need the following installed.  If you do not have them, run the command after the package name. You can test if they are found by just typing the command name. If it says command not found, you need to install it.
+
Your Debian/Ubuntu installation will need the following installed.  If you do not have them, run the command after the package name. You can test if they are found by just typing the command name. If it says command not found, you need to install it.
  
 
{| border="1"
 
{| border="1"
 
|+  
 
|+  
|'''git''' || sudo apt-get install git
+
|'''git''' || <code>sudo apt-get install git</code>
 
|-
 
|-
|'''gcc''' || sudo apt-get install build-essential
+
|'''gcc''' || <code>sudo apt-get install build-essential</code>
 
|-
 
|-
|'''python''' || sudo apt-get install python
+
|'''python''' || <code>sudo apt-get install python</code>
 
|-
 
|-
|'''curl''' || sudo apt-get install curl
+
|'''curl''' || <code>sudo apt-get install curl</code>
 
|-
 
|-
|'''unzip''' || sudo apt-get install unzip
+
|'''unzip''' || <code>sudo apt-get install unzip</code>
 
|}
 
|}
  
If you're uncertain at all, and you're using Ubuntu 12.04, just cut and paste the following. If they are already installed, they'll be skipped.
+
If you're uncertain at all, just cut and paste the following. If some of these packages are already installed and up-to-date, they'll be skipped.
  
 
  sudo apt-get install git build-essential python curl unzip
 
  sudo apt-get install git build-essential python curl unzip
Line 27: Line 27:
 
'''Note:''' If you are a beginner with Ubuntu Linux Distribution, you should update all the packages on your system to avoid problems when you will compile.
 
'''Note:''' If you are a beginner with Ubuntu Linux Distribution, you should update all the packages on your system to avoid problems when you will compile.
  
'''NOTE:''' If you are using x64 ubuntu you also need to install the following package
+
'''Note:''' If you are using x64 ubuntu you also need to install the following package
  
 
{| border="1"
 
{| border="1"
 
|+  
 
|+  
|'''ia32-libs and g++-multilib''' || sudo apt-get install ia32-libs g++-multilib
+
|'''ia32-libs and g++-multilib''' || <code>sudo apt-get install ia32-libs g++-multilib</code>
 
|-
 
|-
 
|}
 
|}
  
 
+
==Start setup==
====Start setup====
 
  
 
*Create a WOCE directory, we recommend you place it in your home directory.
 
*Create a WOCE directory, we recommend you place it in your home directory.
*Clone down the woce-build repo from github. '''git clone https://www.github.com/woce/woce-build'''
+
*Clone down the woce-build repo from github
*Start the build. this is as simple as cd'ing into the woce-build directory and ruuning '''make''' or if you have multiple cores '''make -j<number of cores here>'''
+
git clone <nowiki>https://www.github.com/woce/woce-build</nowiki>
* IMPORTANT: Ignore patch failures for now, it's a known issue
+
*Start the build. This is as simple as cd'ing into the woce-build directory and running '''make''' or if you have multiple cores '''make -j<number of cores here>'''
*When the build finishes the binary's will be under the packages folder in their appropriate directories
+
*IMPORTANT: Ignore patch failures for now, it's a known issue
 +
*When the build finishes the binaries will be under the packages folder in their appropriate directories (e.g. LunaSysMgr in <code>./packages/sysmgr/luna-sysmgr/build/armv7-stage/release-topaz/LunaSysMgr</code>)
  
===Installing the Binaries===
+
==Installing the Binaries==
 +
novacom run -- file:///sbin/stop LunaSysMgr
 +
novacom put file:///usr/bin/LunaSysMgr ./packages/sysmgr/luna-sysmgr/build/armv7-stage/release-topaz/LunaSysMgr
 +
novacom run -- file:///sbin/start LunaSysMgr
  
Instructions Coming Soon
+
==Done!==
 +
'''You're done!''' Your very own LunaSysMgr should now start on your TouchPad.
  
==You're Done!==
+
Don't forget to join the IRC channel [irc://irc.freenode.net/webos-ports #webos-ports on Freenode] and report any issues to [http://issues.webos-ports.org/ WebOS Port's bugtracker]. Oh, and contribute your code changes!

Revision as of 18:36, 27 June 2012

Supported Platforms

Currently the only supported platform is Ubuntu 12.04. We have tested and confirmed that x32 and x64 Ubuntu Desktop and Server successfully build WOCE. Other platforms may work but are not supported.

Older versions of Ubuntu may also work, it's been tested successfully on Ubuntu 10.10. It's also very likely that you'll have success with Debian or Debian-based distributions.

Prerequisites on Debian-based systems

Your Debian/Ubuntu installation will need the following installed. If you do not have them, run the command after the package name. You can test if they are found by just typing the command name. If it says command not found, you need to install it.

git sudo apt-get install git
gcc sudo apt-get install build-essential
python sudo apt-get install python
curl sudo apt-get install curl
unzip sudo apt-get install unzip

If you're uncertain at all, just cut and paste the following. If some of these packages are already installed and up-to-date, they'll be skipped.

sudo apt-get install git build-essential python curl unzip

Note: If you are a beginner with Ubuntu Linux Distribution, you should update all the packages on your system to avoid problems when you will compile.

Note: If you are using x64 ubuntu you also need to install the following package

ia32-libs and g++-multilib sudo apt-get install ia32-libs g++-multilib

Start setup

  • Create a WOCE directory, we recommend you place it in your home directory.
  • Clone down the woce-build repo from github
git clone https://www.github.com/woce/woce-build
  • Start the build. This is as simple as cd'ing into the woce-build directory and running make or if you have multiple cores make -j<number of cores here>
  • IMPORTANT: Ignore patch failures for now, it's a known issue
  • When the build finishes the binaries will be under the packages folder in their appropriate directories (e.g. LunaSysMgr in ./packages/sysmgr/luna-sysmgr/build/armv7-stage/release-topaz/LunaSysMgr)

Installing the Binaries

novacom run -- file:///sbin/stop LunaSysMgr
novacom put file:///usr/bin/LunaSysMgr ./packages/sysmgr/luna-sysmgr/build/armv7-stage/release-topaz/LunaSysMgr
novacom run -- file:///sbin/start LunaSysMgr

Done!

You're done! Your very own LunaSysMgr should now start on your TouchPad.

Don't forget to join the IRC channel #webos-ports on Freenode and report any issues to WebOS Port's bugtracker. Oh, and contribute your code changes!