Difference between revisions of "Device Status"

From WebOS-Ports
Jump to: navigation, search
Line 39: Line 39:
 
|                                Disappears when focus lost            || {{CellStatus|OK}}      || {{CellStatus|OK}}      || {{CellStatus|OK}}    ||
 
|                                Disappears when focus lost            || {{CellStatus|OK}}      || {{CellStatus|OK}}      || {{CellStatus|OK}}    ||
 
|-
 
|-
|                                Language switch                      || {{CellStatus|OK}}      || {{CellStatus|OK}}      || {{CellStatus|OK}}   ||
+
|                                Language switch                      || {{CellStatus|OK}}      || {{CellStatus|OK}}      || {{CellStatus|OK}}     ||
 
|-
 
|-
|                                Additional keys on long-press touch  || {{CellStatus|OK}}      || {{CellStatus|OK}}      || {{CellStatus|OK}}   ||
+
|                                Additional keys on long-press touch  || {{CellStatus|OK}}      || {{CellStatus|OK}}      || {{CellStatus|OK}}     ||
 
|-
 
|-
|                                Suggestions                          || {{CellStatus|?}}      || {{CellStatus|KO}}     || {{CellStatus|KO}}    ||
+
|                                Suggestions                          || {{CellStatus|?}}      || {{CellStatus|REG}}     || {{CellStatus|REG}}    ||
 
|-
 
|-
 
|rowspan="5"| WiFi            || Selection in system menu              || {{CellStatus|Partial}} || {{CellStatus|Partial}} || {{CellStatus|N/A}}    || Fails to connect if already connected to another network
 
|rowspan="5"| WiFi            || Selection in system menu              || {{CellStatus|Partial}} || {{CellStatus|Partial}} || {{CellStatus|N/A}}    || Fails to connect if already connected to another network

Revision as of 12:42, 11 May 2019

Status clarifications

Status Meaning
OK Works fine
Partial Works partially but is stable
Unstable Crashes / freezes / glitches
KO Not working, like previously
REG Not working, but has been known to work
N/A Not Applicable/Not Available
? Not tested / Don’t remember
Category Step tenderloin tissot qemux86-64 comment
Build date 2019-apr-26 2019-may-06 2019-apr-28
Flash/Sideload Installation OK OK OK
Boot LuneOS logo shows up OK OK OK
FirstUse app Content shows up OK OK OK
Widgets have LuneOS theme OK OK OK
Wifi selection works Partial Partial N/A Status isn’t updated while connecting
"Normal" UI after firstuse is ended OK OK OK
Virtual keyboard Shows up on focus Partial OK Partial 2019-apr-26 build: Need to restart maliit for it to behave, qemux86-64: empty surface
Disappears when focus lost OK OK OK
Language switch OK OK OK
Additional keys on long-press touch OK OK OK
Suggestions ? REG REG
WiFi Selection in system menu Partial Partial N/A Fails to connect if already connected to another network
Selection in preferences app Partial Partial N/A Fails to connect if already connected to another network
On/Off switch OK OK N/A
Indicator OK OK N/A
Keeps configuration between reboots OK OK N/A
Bluetooth Selection in system menu N/A N/A N/A Should it be possible ?
Selection in preferences app KO ? N/A List shows up fine, coupling not tested
On/Off switch KO OK N/A
Indicator KO OK N/A
Keeps configuration between reboots KO OK N/A
Backlight On/Off switch with Power key OK OK N/A
Intensity with system menu Partial OK N/A Max intensity sometimes seems unreachable
Gyroscope UI follows rotation OK OK N/A
Rotation lock in system menu ? OK N/A
Sound Boot startup sound OK OK OK
Vol+/Vol- on-screen indicator OK OK N/A
Volume is actually adjusted OK OK N/A
Telephony SIM operator in status bar N/A ? N/A
GSM signal strength in status bar N/A OK N/A
Call a number N/A ? N/A
Receive a call N/A ? N/A
SMS Sens SMS N/A ? N/A
Receive SMS N/A ? N/A
Compositor Switch card view / maximized card OK OK OK
Card view : horizontal scroll OK OK OK
Discard card with swipe up OK OK OK
Stack cards OK OK OK
App name is shown when card maximized OK OK OK
Gesture Area Swipe up or tap to go to card view OK OK OK
Swipe left ( « back » ) OK OK OK
Swipe right to take screenshot OK OK OK
Testr GPS ? KO N/A No position found
Banners ? OK OK
Apps QML Apps (Browser, Phone apps) OK OK OK
Enyo Apps (Messages, Maps…) OK OK Partial email app stays blank: 'LunaWebAppManager[671]: [671:671:0505/102822.211552:INFO:CONSOLE(54)] "Uncaught TypeError: Cannot read propert

y 'addListener' of undefined", source: file:///usr/palm/applications/com.palm.app.email//mail/source/Accounts.js (54)'

JustType shows up and search works OK OK OK